How did I prevent Windows 10 from rebooting automatically?

  1. Click on the “Start” button, type gpedit.msc, and press Enter.
  2. In the Local Group Policy Editor, go to
    Computer «Configuration» → «Administrative Templates» → «Windows Components» → «Windows Update»
  3. Double-click on «No auto-restart with automatic installations of scheduled updates».
  4. Select «Enabled», and then click «OK».

answers.microsoft.com/en-us/windows/forum/all/disable-windows-10-automatic-restart-after-updates/16f1826d-a796-4de8-ac99-1d625420d265

Specifies that to complete a scheduled installation, Automatic Updates will wait for the computer to be restarted by any user who is logged on, instead of causing the computer to restart automatically.

If the status is set to Enabled, Automatic Updates will not restart a computer automatically during a scheduled installation if a user is logged in to the computer. Instead, Automatic Updates will notify the user to restart the computer.

Be aware that the computer needs to be restarted for the updates to take effect.

If the status is set to Disabled or Not Configured, Automatic Updates will notify the user that the computer will automatically restart in 5 minutes to complete the installation.

Note: This policy applies only when Automatic Updates is configured to perform scheduled installations of updates. If the "Configure Automatic Updates" policy is disabled, this policy has no effect.