How have I fixed «InnoDB: Semaphore wait has lasted > 600 seconds. We intentionally crash the server because it appears to be hung.»

mysql

(Dmitry Fedyuk) #1

These 3 settings fixed the issue. I do not know which one exactly.

innodb_flush_neighbors = 0
thread_cache_size = 100
table_open_cache = 50000

bugs.launchpad.net/percona-server/+bug/1653764/comments/15